58股票网今日更新股票软件: 12 个 共有股票软件公式: 37059 个 总容量: 135.317 G | 共有文章: 7472设为首页 加入收藏
通达信 大智慧 同花顺 飞狐 分析家 操盘手 指南针 自动交易
您当前位置:首页 > 股票软件公式 > 同花顺公式

    主图,解盘,赢富,大智慧羸富解盘主图指标公式

  • 时间:2015-07-04 19:30:46  来源:  作者:
  • input: n(5,0,999,1),n1(10,0,999,1),n2(20,0,999,1),n3(30,0,999,1);
    A74:=MA(CLOSE,20);
    A75:=(CLOSE > MA(CLOSE,5));
    A76:=(MA(CLOSE,5) > MA(CLOSE,10));
    A77:=(CLOSE > MA(CLOSE,10));
    A78:=(MA(CLOSE,5) > MA(CLOSE,20));
    A79:=(CLOSE > MA(CLOSE,20));
    A710:=REF(A74,1);
    A711:=(A74 > A710);
    AVX:=(((((IF(A75,10,(0 - 10)) + IF(A76,10,(0 - 10))) + IF(A77,10,(0 - 10))) + IF(A78,10,(0 - 10))) + IF(A79,10,(0 - 10))) + IF(A711,10,(0 - 10)));
    DSLX:=(CLOSE / INDEXC);
    DSLX1:=MA(DSLX,5);
    DSLX2:=MA(DSLX,10);
    V1:=MA(VOL,5);
    V2:=MA(VOL,10);T := BARSLAST(DISPSTATUS=1)+1;
    T := BARSLAST(DISPSTATUS=1)+1;
    HHg := HHV(H, T);
    ddg := LLV(L, T);
    {Hk := LL-HH; G12 := LL-HK*1.55; }
    IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
    DRAWTEXTABS(12,70,'该股的量能,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右。 '),color0000FF,LINETHICK3;
    IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
    DRAWTEXTABS(12,70,'该股虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右。 '),color0000FF,LINETHICK3;
    IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 > V2)) AND (DSLX < DSLX1)) THEN
    DRAWTEXTABS(12,70,'该股量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右。 '),color0000FF,LINETHICK3;
    IF BARSTATUS=2 and c<200 and ((CROSS(AVX,1) AND (V1 <= V2)) AND (DSLX < DSLX1)) THEN
    DRAWTEXTABS(12,70,'该股形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右。 '),color0000FF,LINETHICK3;
    IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
    DRAWTEXTABS(12,70,'该股形态变坏,但走势相对其它股票尚可,重仓者减持大半,清仓者可以观望。 '),color00FF00,LINETHICK3;
    IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
    DRAWTEXTABS(12,70,'该股随大盘一起下跌,程明显缩量走势,考虑到大盘风险,减持或清仓。 '),color00FF00,LINETHICK3;
    IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
    DRAWTEXTABS(12,70,'该股放量下跌,走势明显偏弱,离场观望。 '),color00FF00,LINETHICK3;
    IF BARSTATUS=2 and c<200 and ((CROSS(1,AVX) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
    DRAWTEXTABS(12,70,'该股缩量下跌,走势偏弱,离场观望。 '),color00FF00,LINETHICK3;
    IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
    DRAWTEXTABS(12,70,'该股形态良好,强势明显,量能充足,可以继续持有。 '),color00FFFF,LINETHICK3;
    IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
    DRAWTEXTABS(12,70,'该股上行趋势不变,强势依然,但量能开始转弱,注意风险。 '),color00FFFF,LINETHICK3;
    IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
    DRAWTEXTABS(12,70,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。 '),color00FFFF,LINETHICK3;
    IF BARSTATUS=2 and c<200 and ((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
    DRAWTEXTABS(12,70,'该股走势趋弱,量能不足,减持大部分筹码。 '),color00FFFF,LINETHICK3;
    IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)) THEN
    DRAWTEXTABS(12,70,'该股形态不佳,注意成交量的变化,但目前不适合参与。 '),COLOR00FF00,LINETHICK3;
    IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX >= DSLX1)) THEN
    DRAWTEXTABS(12,70,'该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。 '),COLOR00FF00,LINETHICK3;
    IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) AND (DSLX < DSLX1)) THEN
    DRAWTEXTABS(12,70,'该股有走强迹象,但量能不足,趋势不明,不适合操作。 '),COLOR00FF00,LINETHICK3;
    IF BARSTATUS=2 and c<200 and ((((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) AND (DSLX < DSLX1)) THEN
    DRAWTEXTABS(12,70,'该股走势太弱,没有参与价值。 '),COLOR00FF00,LINETHICK3;
    IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 >= V2)) THEN
    DRAWTEXTABS(12,70,'大盘量能,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右, '),color0000FF,LINETHICK3;
    IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 >= V2)) THEN
    DRAWTEXTABS(12,70,'如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎。 '),color0000FF,LINETHICK3;
    IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 < V2)) THEN
    DRAWTEXTABS(12,70,'大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌, '),color0000FF,LINETHICK3;
    IF BARSTATUS=2 and c>200 and (CROSS(AVX,1) AND (V1 < V2)) THEN
    DRAWTEXTABS(12,70,'可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入。 '),color0000FF,LINETHICK3;
    IF BARSTATUS=2 and c>200 and (CROSS(1,AVX) AND (V1 >= V2)) THEN
    DRAWTEXTABS(12,70,'大盘形态走坏,重仓者可以减去大部分仓位。 '),color00FF00,LINETHICK3;
    IF BARSTATUS=2 and c>200 and (CROSS(1,AVX) AND (V1 < V2)) THEN
    DRAWTEXTABS(12,70,'大盘缩量调整,注意风险,短线清仓观望。 '),color00FF00,LINETHICK3;
    IF BARSTATUS=2 and c>200 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) THEN
    DRAWTEXTABS(12,70,'大盘走势良好,量能,可以继续持有强势股。 '),color00FFFF,LINETHICK3;
    IF BARSTATUS=2 and c>200 and (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 < V2)) THEN
    DRAWTEXTABS(12,70,'大盘形态良好,但量能稍显不足,随时准备减仓。 '),color00FFFF,LINETHICK3;
    IF BARSTATUS=2 and c>200 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 >= V2)) THEN
    DRAWTEXTABS(12,70,'大盘趋势不明,注意成交量变化,目前不适宜进场。 '),COLOR00FF00,LINETHICK3;
    IF BARSTATUS=2 and c>200 and (((AVX < 1) AND (REF(AVX,1) < 0)) AND (V1 < V2)) THEN
    DRAWTEXTABS(12,70,'大盘趋势向下,量能萎缩,不适合进场。 '),COLOR00FF00,LINETHICK3;
    var100:='所属板块:';
    if inblock('电力')=1 then var100:=var100+' 电力';
    if inblock('电脑')=1 then var100:=var100+' 电脑';
    if inblock('电器')=1 then var100:=var100+' 电器';
    if inblock('电子信息')=1 then var100:=var100+' 电子信息';
    if inblock('房地产')=1 then var100:=var100+' 房地产';
    if inblock('纺织服装')=1 then var100:=var100+' 纺织服装';
    if inblock('钢铁')=1 then var100:=var100+' 钢铁';
    if inblock('工程建筑')=1 then var100:=var100+' 工程建筑';
    if inblock('供水供气')=1 then var100:=var100+' 供水供气';
    if inblock('化工')=1 then var100:=var100+' 化工';
    if inblock('化纤')=1 then var100:=var100+' 化纤';
    if inblock('机械')=1 then var100:=var100+' 机械';
    if inblock('建材')=1 then var100:=var100+' 建材';
    if inblock('交通工具')=1 then var100:=var100+' 交通工具';
    if inblock('交通设施')=1 then var100:=var100+' 交通设施';
    if inblock('教育传媒')=1 then var100:=var100+' 教育传媒';
    if inblock('金融')=1 then var100:=var100+' 金融';
    if inblock('旅游酒店')=1 then var100:=var100+' 旅游酒店';
    if inblock('煤炭石油')=1 then var100:=var100+' 煤炭石油';
    if inblock('酿酒食品')=1 then var100:=var100+' 酿酒食品';
    if inblock('农林牧渔')=1 then var100:=var100+' 农林牧渔';
    if inblock('其他行业')=1 then var100:=var100+' 其他行业';
    if inblock('汽车')=1 then var100:=var100+' 汽车';
    if inblock('汽配')=1 then var100:=var100+' 汽配';
    if inblock('商业连锁')=1 then var100:=var100+' 商业连锁';
    if inblock('石化')=1 then var100:=var100+' 石化';
    if inblock('通信')=1 then var100:=var100+' 通信';
    if inblock('外贸')=1 then var100:=var100+' 外贸';
    if inblock('医药')=1 then var100:=var100+' 医药';
    if inblock('仪电仪表')=1 then var100:=var100+' 仪电仪表';
    if inblock('有色金属')=1 then var100:=var100+' 有色金属';
    if inblock('运输物流')=1 then var100:=var100+' 运输物流';
    if inblock('造纸印刷')=1 then var100:=var100+' 造纸印刷';
    if inblock('安徽')=1 then var100:=var100+' 安徽';
    if inblock('北*京')=1 then var100:=var100+' 北*京';
    if inblock('福建')=1 then var100:=var100+' 福建';
    if inblock('甘肃')=1 then var100:=var100+' 甘肃';
    if inblock('广东')=1 then var100:=var100+' 广东';
    if inblock('广西')=1 then var100:=var100+' 广西';
    if inblock('贵州')=1 then var100:=var100+' 贵州';
    if inblock('海南')=1 then var100:=var100+' 海南';
    if inblock('河北')=1 then var100:=var100+' 河北';
    if inblock('河南')=1 then var100:=var100+' 河南';
    if inblock('黑龙江')=1 then var100:=var100+' 黑龙江';
    if inblock('湖北')=1 then var100:=var100+' 湖北';
    if inblock('湖南')=1 then var100:=var100+' 湖南';
    if inblock('吉林')=1 then var100:=var100+' 吉林';
    if inblock('江苏')=1 then var100:=var100+' 江苏';
    if inblock('江西')=1 then var100:=var100+' 江西';
    if inblock('辽宁')=1 then var100:=var100+' 辽宁';
    if inblock('内蒙古')=1 then var100:=var100+' 内蒙古';
    if inblock('宁夏')=1 then var100:=var100+' 宁夏';
    if inblock('青海')=1 then var100:=var100+' 青海';
    if inblock('山东')=1 then var100:=var100+' 山东';
    if inblock('山西')=1 then var100:=var100+' 山西';
    if inblock('陕西')=1 then var100:=var100+' 陕西';
    if inblock('上海')=1 then var100:=var100+' 上海';
    if inblock('深圳')=1 then var100:=var100+' 深圳';
    if inblock('四川')=1 then var100:=var100+' 四川';
    if inblock('天津')=1 then var100:=var100+' 天津';
    if inblock('***')=1 then var100:=var100+' ***';
    if inblock('新*疆')=1 then var100:=var100+' 新*疆';
    if inblock('云南')=1 then var100:=var100+' 云南';
    if inblock('浙江')=1 then var100:=var100+' 浙江';
    if inblock('重庆')=1 then var100:=var100+' 重庆';
    if inblock('3G')=1 then var100:=var100+' 3G';
    if inblock('H股')=1 then var100:=var100+' H股';
    if inblock('QFII持股')=1 then var100:=var100+' QFII持股';
    if inblock('ST')=1 then var100:=var100+' ST';
    if inblock('奥*运')=1 then var100:=var100+' 奥*运';
    if inblock('创投')=1 then var100:=var100+' 创投';
    if inblock('次新股')=1 then var100:=var100+' 次新股';
    if inblock('大盘')=1 then var100:=var100+' 大盘';
    if inblock('股权改革')=1 then var100:=var100+' 股权改革';
    if inblock('股权投资')=1 then var100:=var100+' 股权投资';
    DD:=FINANCE2(35);
    SS:=FINANCE2(37);
    GG:=FINANCE2(3);
    TH:=DYNAINFO(39);
    DRAWTEXTABS(8,30,'总股本:'+NUMTOSTRn(DD,0)+'万股' +' 流通A股:'+NUMTOSTRn(SS,0)+'万股'+'市盈率:'+NUMTOSTRn(TH,2)+' 倍'+' 每股收益:'+NUMTOSTRn(GG,3)+' 元'),ColorFFFFDD;
    DRAWTEXTABS(8,50,var100+' '),ColorFFDE00;
    SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);
    DRAWTEXTABS(5,5,'股旁网 www.gupang.com'),linethick1,COLOR00EEff;
    DRAWTEXTREL(12,5,'量能饱和度:'+NUMTOSTRN(SAT,0)),LINETHICK3,Color8000FF;
    AA10:MA(CLOSE,8),color0000FF;
    AA12:MA(CLOSE,12),color0000FF;
    BB10:=((ATAN((AA10 - REF(AA10,1))) * 3.1416) * 10);
    BB12:=((ATAN((AA12 - REF(AA12,1))) * 3.1416) * 10);
    MA13:=MA(CLOSE,13);
    FILLRGN(AA10,AA12,(((AA12 <= AA10) AND (BB12 >= 1)) AND (BB10 >= 1))),Color0098FF;
    FILLRGN(AA10,AA12,(((AA12 >= AA10) AND (BB10 <= 1)) AND (BB10 <= 1))),color00FF00;
    x1:=(C+L+H)/3;
    bb13:=atan(ema(x1,13)-ref(ema(x1,13),1))*3.1416*10;
    ema8:=ema(c,8);
    DRAWTEXT(filter(bb13>1 and ema(x1,13)>ref(ema(x1,8),1),10),
    ema8,'∠45上升'),colorwhite;
    压力:MA(REF(HHV(C,30),1),2),Color9DFFFF;
    支撑:MA(REF(LLV(C,30),1),2),ColorABFF46;
    AA1:=AMOUNT/V;
    BB1:=L<AA1*0.9;
    CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
    DD1:=L<MA(C,5)*0.921;
    EE1:=V<MA(V,5)*1.5;
    FF1:=BB1 AND CC1 AND DD1 AND EE1;
    DRAWTEXT(ff1,(LOW* 0.99),'老鼠仓'),Color4080FF;
    A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
    黑马线:=EMA(A51,5);
    A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
    趋势线:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));
    DRAWTEXT(CROSS(趋势线,0)AND 黑马线<40,(HIGH* 0.97),'▲大黑马'),COLORYELLOW;
    LC:=REF(CLOSE,1);
    RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
    FF:=EMA(CLOSE,3);
    MA15:=EMA(CLOSE,21);
    DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'B'),Coloryellow;
    DRAWTEXT(CROSS(88,RSI),(HIGH * 1.02),'S'),Colorgreen;
    VAR2:=LLV(LOW,27);
    VAR3:=HHV(HIGH,34);
    VAR4:=EMA((CLOSE-Var2)/(Var3-Var2)*4,4)*25;
    注意买:=IF((Var4<10),80,100);
    RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
    K:=SMA(RSV,3,1);
    D:=SMA(K,3,1);
    J:=3*K-2*D;
    超跌:=IF(J<0,10,0);
    BDDD:=LLV(J,2)=LLV(J,8);
    买入:=IF(CROSS(J,REF(J+0.01,1)) AND BDDD AND J<20,30,0);
    DRAWTEXT(买入 AND 注意买=100 AND 超跌=0,low,'短线'),Color8000FF;
    MTM:=C-REF(C,1);
    DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
    买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
    DRAWTEXT(filter(买=1,5),LOW-0.03,'拉升'),ColorFFDE00;

     

  • 0
  • 0
  • 您看到此篇文章时的感受:已有 人表态!
热门关键词
大智慧好用的公式 热度
同花顺好用的公式 热度